Debubg session stuck in "LDR R0, =SystemInit"

Hi everybody,

I'm working on a Arm Cortex M0+ Micrcontroller (UT32M0R500 from Cobham) and I have been using the debug session for one week without any trouble.

However, yesterday, the debug session started to do strange thinks like jumping some C instructions. And now, the program is stuck at the line "LDR R0, = SystemInit".

The SystemInit file might not be the problem because it is provided by the constructor, it worked before and it is very simple.

On the assembly code, it is stuck at the address 0x00000222. 

I tried to recompile, restart the debug session, reset the micrcontroller, load examples and nothing change.

If I'm not wrong, the 0x00000222 address correspond to a Handler_IRQ  for the Cortex M0+ ?

I don't understand what is the error :

What could be the problem ? And How can I solve it ?

When I tried this morning, everything looked good until Keil jumps some C instructions and gets stuck again.

Thank you for your help.

Best regards.

Rémi G

Parents Reply Children
No data