No Debug symbol is visible on Arm Cortex R52 FVP on Arm DS(Version: 2021.2)


I am using FVP for Cortex R52 :

Debug connection is working fine, but I am facing issue that debugging is only possible in Disassembly, not with the Debug symbols. I checked my compilation :

armclang.exe --target=arm-arm-none-eabi -march=armv8-r -marm -mcpu=Cortex-R52 -xc -std=c99 -O0 -g -gdwarf-3 -MD -MP -c -o

with this no Debug symbols, I could verify when I run 

fromelf.exe  Debug01.axf , there is no links to source files etc.

Can you please help in solving this issue, I am using  Arm Development Studio IDE : 

Version: 2021.2
Build: 202120914



  • Hi Avinash

    My name is Stephen and I work at Arm.  

    As a first step, please try the ready-made "startup_Cortex-R52" example that is supplied with Arm DS, via
    File > Import > Arm Development Studio > Examples and Programming Libraries

    I tried to reproduce what you are seeing by using that example as a basis, with your compile-line, but I was able to debug at source-level as expected (see screenshot).

    One possible cause of what you are seeing is that the debugger has loaded the debug symbols for Hypervisor H: state, but your application code is running in another state, e.g. Secure S: or Normal (or Non-secure) N: states.

    You must load symbols for the state in which your application runs, with e.g.
    add-symbol-file your.axf N:0

    Your compile-line could be simplified from:
    armclang.exe --target=arm-arm-none-eabi -march=armv8-r -marm -mcpu=Cortex-R52 -xc -std=c99 -O0 -g -gdwarf-3 -MD -MP -c -o
    armclang --target=arm-arm-none-eabi -marm -mcpu=Cortex-R52 -xc -std=c99 -O0 -g -MD -MP -c -o

    (Specify either -march or -mcpu, but not both.  And there's probably no need for you to specify a dwarf version explicitly).

    To view the debug information in an executable, use:
    "fromelf -g your.axf"

    Hope this helps