This discussion has been locked.
You can no longer post new replies to this discussion. If you have a question you can start a new discussion

Failed to load "<project>.axf" - ERROR (CMD16-TAD274-NAL22) - Can't run bare-metal application from SDRAM.



I have been following this Bare-Metal User Guide in ARM Development Studio (even though it is written for DS-5) in an attempt to get a bare-metal "Hello World" running from SDRAM. Following the guide, I have successfully ran it from OCRAM. 

I am stuck at the last step for running the application from SDRAM: I run the preloader (a u-boot-spl file; see the guide in the Preloader section) and my Commands console (see screenshot #1 below) looks very close to Figure 36 (their tutorial author's output after running the preloader). So far so good? 


Then, once I run the actual "Hello World" debug configuration, I get the error in screenshot #2, which, according to the guide, is the exact error received when the preloader has not yet brought up SDRAM. Hence, even though my preloader seems to be working (since my output upon running it looks the same as the guide's), the SDRAM is not being brought up.


Are there any hints in my screenshots or provided information regarding why the preloader (again, attached) isn't doing it's job and bringing up the SDRAM?