Who can help me with debug session problem?

Hello

I work with Tiva C Series LaunchPad, exactly EK-TM4C123GXL evaluation kit in Keil uVision. The problem is when I start a debug session, it stop immediately without any error message, and it happens with any project. Who works with the same board? Who have the same project?

The actual project is about a simple ADC reading, with CMSIS-CORE for Cortex-M and System Startup for TM4C123x Series. The code is:

#include "TM4C123.h"                                // Device header

int result;															// Variable to value of ADC conversion

/* Main Function */
int main(void) {
	
	SYSCTL->RCGCGPIO |= 0x10;						// Enable clock access to PORTE
	SYSCTL->RCGCADC |= 0x1;							// Enable clock access to ADC0
	
	GPIOE->AFSEL |= 0x8;							// Set PE3 with alternative function
	GPIOE->DEN &= ~0x8;								// Set no PF3 ditial pin
	GPIOE->AMSEL |= 0x8;							// Set PE3 analog pin
	
	/* ADC0 Initialization */
	ADC0->ACTSS &= ~0x8;							// Disable SS3
	ADC0->EMUX &= ~0xF000;							// Software Trigger conversion in SS3
	ADC0->SSMUX3 = 0;								// AIN0 in sample 1, SS3
	ADC0->SSCTL3 |= 0x6;							// One sample, 1st last sample
	ADC0->ACTSS |= 0x8;								// Enable SS3
	
	/* Infite Loop */
	while(true) {
		
		ADC0->PSSI |= 0x8;							// Start conversion at SS3
		while(!(ADC0->RIS & 0x8));					// Wait for conversion complete
		result = ADC0->SSFIFO3;						// Value of conversion
		ADC0->ISC |= 0x8;							// Clear flag of end conversion
		
	}

}

I expect anybody have a solution.

More questions in this forum