GA fragment count / gpu settings

I'm using Graphics Analyzer 5.7.0 from ARM Mobile Studio Starter Edition 2020.3.

1. I tried to capture a trace with fragment count enabled. The frame has 2 render passes. I can see valid fragment count in pass #1, but all zeroes in pass #0.

    What do I miss here? I'm sure pass #0 did rendered something.

2. According to User Guide, cycles in Shader View is coming from Mali Offline Compiler for Mali-T880.  Is it possible to change to other GPU, say Mali-G78?

  • Hi sabre, 

    I'll check with the engineering team for the fragment count behavior to see if we have any known issues here. 

    The the offline compiler the current tool only supports Mali-T880; if you want other GPUs you'll need to use the standalone Mali Offline Compiler shipped in Mobile Studio. We're working on a new major version of the tool, and getting this fixed for that version is definitely on the todo list. 

    Kind regards, 
    Pete

  • A late follow up here - sorry it took some time to reply. 

    The fragment count mode uses shader replacement to emit instrumentation to a color attachment. It will not work for render passes that have no color attachment (e.g. depth shadow maps), or for cases where shader replacement fails. 

    We've fixed a number of issues with float attachments in Mobile Studio 2021.2, so please give it a go an let us know if that helps. If it doesn't please can you share your .mgd file so we can see the behavior which is causing the problem. 

    Kind regards, 
    Pete

More questions in this forum