ULINK not being recognized in Vista 64

I recently bought a laptop with Windows Vista 64. I have tried to install uVision (mdk370.exe) along with ULINK various times with no success.

The last time I tried...
-The user account control (UAC) was disabled.

-I uninstalled removed uVision

-I uninstalled ULINK as described in "ULINK:REINSTALLING USB DRIVER". I could only find the two files keilul.inf, keilul.sys and I deleted both.

-I then restarted the computer.

-I installed uVision (mdk370.exe) - right click "Run as Administrator"

-I then restarted the computer.

-I installed the USB drivers (USBDrivers.exe, file version 1.4.0.1, product version 1.04) - right click "Run as Administrator"

-I then restarted the computer.

-I plugged ULINK into computer (other end of ULINK was already plugged into MCB2140 board)

-I plugged MCB2140 board into computer

-vista detected both devices had been installed (the two sounds)

-the found new hardware box dialog appeared

-instead of working with that dialog, I opened up the device manager (Control Panel--> Device Manager)

-the ULINK device appeared in ADMIN-PC-->Other devices-->Unknown device. (I know this is the ULINK for two reasons. First, this is the entry that appears/desappears when the device is plugged in/unplugged. Second, the Hardware Ids is: USB\VID_C251&PID_2710&REV_0002, USB\VID_C251&PID_2710)

-I right clicked the unknown device (ULINK) and selected "Update Driver Software" (while connected to the internet)

-I selected the automatic search

-the result: "Windows was unable to install your
Unknown Device", "Windows could not find driver software for your device".

-I then went back to the original "found new hardware" dialog box that appeared immediately after installing the devices and selected to find the software automatically. The result was the same.

The last time I used these devices (ULINK and MCB2140) on my desktop (Windows XP), they both worked.

Does anyone have any idea what the problem may be? Thanks for your help.

More questions in this forum