"armclang: error" in Simulink when using FVP target


I'm trying to follow the tutorial here (community.arm.com/.../develop-embedded-control-systems-efficiently-in-matlab-with-arm-models-and-compiler-integration) to run the Simulink example 'ArmCortexM_FM_pil_top' on an FVP of the Cortex-M4. I downloaded Arm DS to provide the access to the FVPs and the Arm compilers, and am using an evaluation license.

Per the tutorial, I have already set my environment variables:

ARM_PRODUCT_PATH = C:\Program Files\Arm\Development Studio 2020.0\sw\mappings


ARMLMD_LICENSE_FILE = C:\Users\<my username>\AppData\Roaming\ARM\ds\licenses\DS000-EV-31030.lic

The ARMLD_LICENSE _FILE path directly above is pointing to the evaluation license that the Arm License Manager automatically generated for me. This was initially somehow not registering with DS, so a support agent sent me a copy of my license.dat file directly, and I also tried with the variable set for that file:

ARMLMD_LICENSE_FILE = C:\Program Files\Arm\Development Studio 2020.0\license.dat

But both values for that variable gave me the same error in Simulink when I tried to run the model:

armclang: error: Your installation could be misconfigured or corrupted.

armclang: note:

Check that your licensing and toolkit configuration is set up correctly, using the information available at: developer.arm.com/.../product-and-toolkit-configuration.

armclang: note:

Information about this error is available at: ds.arm.com/.../lic86

 General licensing information is available at: ds.arm.com/.../

 If you need further help, provide this complete error report to your supplier or license.support@arm.com.


 - LM_LICENSE_FILE: 'C:\Flexlm\License.dat'


 - ARM_PRODUCT_PATH: 'C:\Program Files\DS-5 v5.29.3\sw\mappings'


 - Product location: product not found

 - Toolchain location: C:\PROGRA~1\Arm\DEVELO~1.0\sw\ARMCOM~1.14\bin

 - Selected tool variant: ult

Product: unknown

Component: ARM Compiler 6.14

Tool: armclang [5db06c00]

I cannot understand why in the error log ARMLMD_LICENSE_FILE is showing as 'unset'. I'm using Windows 10, MATLAB/Simulink 2018b. Any help would be greatly appreciated. Cheers!

Parents Reply Children
No data
More questions in this forum