Keil+JTAG Error with S32K148(No Cortex-M Device found in JTAG chain)

Hello,I have encountered a problem:Using JTAG mode for S32K148 download and debugging in Keil IDE will result in an error message."No Cortex-M Device found in JTAG chain".Without changing the hardware environment,I have made the following attempts but have been unable to resolve them, so the preliminary conclusion is that there is a problem between Keil and the MCU。

Attempt 1:Keil+SWD is ok, IAR+SWD/JTAG are both ok, S32DS+SWD/JTAG are both ok.

Attempt 2:I have downgraded the keil dfp pack package version from 1.5.0 to 1.3.0,but none of them worked.

Attempt 3:I replaced Keil's J-Link driver “JLinkARM.dll”, but it still doesn't work

Attempt 4:I can download it separately using the JTAG mode of the Segger J-Flash tool.

Attempt 5:I have also tried changing Keil versions, 5.34 and 5.39, but none of them worked.

So I don't know where the problem is, I suspect it's an internal issue with Keil or an incompatibility issue between Keil and S32K series chips in JTAG mode.

Please help confirm ,thanks.The error report photo is attached.