This discussion has been locked.
You can no longer post new replies to this discussion. If you have a question you can start a new discussion

Keil MDK: Linker show error with a long relative libpath

Error L6002U showed this in the Build log:

.\Objects\WS_Passport_BL.axf: error: L6002U: Could not open file ..\..\..\..\..\..\..\..\..\..\AppData\Local\Arm\Packs_538\Keil\MDK-Middleware\7.16.0\Network\Lib\ARM\Net4_Dbg_CM3_L.lib: No such file or directory

I had checked the above relative path, it is correct, but the Linker couldn't see it.

I tried moving the current project folder to its parent directory, rebuild and it worked again!

So, my assumption is the package which has "long" relative path might cause this linker error.

Btw, these are some additional information about Middleware pack and Compiler toolchain:

Package Vendor: Keil
                Middleware for Keil MDK-Professional and MDK-Plus
   * Component: CORE Variant: IPv4 Debug Version: 7.18.0
   * Component: ETH Version: 7.18.0
   * Component: Legacy API Version: 7.18.0
   * Component: Web Server Compact Variant: HTTP Version: 7.18.0
   * Component: BSD Version: 7.18.0
   * Component: TCP Version: 7.18.0
   * Component: UDP Version: 7.18.0

µVision V5.38.0.0
Copyright (C) 2022 ARM Ltd and ARM Germany GmbH. All rights reserved.

Tool Version Numbers:
Toolchain: MDK Plus 5.38 (Flex): 1 user(s) Version:
Toolchain Path: C:\Keil_v538\ARM\ARMCC_506U7\Bin
C Compiler: Armcc.exe V5.06 update 7 (build 960)
Assembler: Armasm.exe V5.06 update 7 (build 960)
Linker/Locator: ArmLink.exe V5.06 update 7 (build 960)
Library Manager: ArmAr.exe V5.06 update 7 (build 960)
Hex Converter: FromElf.exe V5.06 update 7 (build 960)
Dialog DLL: TCM.DLL V1.56.4.0
Target DLL: UL2CM3.DLL V1.164.8.0
Dialog DLL: TCM.DLL V1.56.4.0