This discussion has been locked.
You can no longer post new replies to this discussion. If you have a question you can start a new discussion

USART Debugging using STM32F407VG Disco board in Keil - can't debug

I've learned that, when debugging a code that utilizes USART, we can't do it over the ST-LINKV2 on the Disco board. 

I found that to achieve this we have to use a usb-to-serial converter. I have the PL2303HXA and i'm using it on my disco with the STM32F407VGT6 MCU. I've tried something but i can't debug. I've also considered the cross connection: tx(converter) - rx(mcu), rx(converter) - tx(mcu), and connected the common grounds and tried both 5V and 3.3V VCC, but still no result.

These are the connections i made:

Note: Here i have the LED1 blinking red (toggling), and when i try to debug like this it says: No ST-LINK detected and this one:

The other thing i did is this:

Here i connected the Mini USB to another usb port on my pc, and the PL2303HXA in another as can be seen.

Here i only get the error:  Error: Flash Download failed - "Cortex-M4"