Target "NUCLEO_WL55JC" is not recognized

Hi!

I am trying to compile both examples: os.mbed.com/.../ and os.mbed.com/.../ on Keyl Studio Cloud. Whenever I try, I always receive the following messages from the compiler:

    Build started
    Target "NUCLEO_WL55JC" is not recognized
    Internal error.
    Build failed
    Build failed

The same examples work well in MBed online IDE (the one that is being deprecated). The problem with Mbed Online is it does not work always (the IDE freezes from time to time) and it is being deprecated. But that belongs to another Forum.

I also tried Mbed Studio 1.4.4 (desktop version) but it does not compile anything, and I am unable to create a new project because "it is not possible to create an Mbed program inside an Mbed program"


The board I am trying to use is STM32WL55 (NUCLEO-WL55JC1): www.st.com/.../stm32wl55jc.html

It is recognized by the Keyl Online IDE (running on Google Chrome).

Thank you in advance for your kind help.


With best regards


Sebastian

  • I did a quick test, but I could not replicate. I imported the examples mentioned above, and they 'just worked'.

    I wonder if there is a cookie issue from before the tool was updated. As a quick test, can you log in with an Incognito browser window and retest. If that works OK, either continue to use that browser, else delete your browser cookies etc.