Can't connect to Android 10 device using lwi_me.py

Hello,

I have an 32-bit Unity application.

I can connect to the Android 9 device using the next command: "python3 lwi_me.py --lwi-mode=capture --32bit".

But when I try to connect to the same application on Android 10 device I got the error:

python3 lwi_me.py --lwi-mode=capture --32bit

--lwi-api=vulkan not specified, assuming GLES application. To use Vulkan, specify --lwi-api=vulkan

--32bit specified, assuming 32bit application

Searching for devices:

    0cd7d2df9906 / Redmi 7A found

Select a device:

    Auto-selected 0cd7d2df9906 / Redmi 7A

Searching for debuggable packages:

    1 debuggable package found           

Select a debuggable packages:

    Auto-selected com.XXXXXXXXXXX

Searching for a Mali GPU:

    No Mali GPU found

Configuring LWI

--lwi-gles-layer-lib-path not specified, assuming /Applications/Arm_Mobile_Studio_2021.3/performance_advisor/lwi/helpers/../target/android/arm/32-bit/libGLES_layer_lwi.so

Enabling GLES debug layer...

Traceback (most recent call last):

  File "/Applications/Arm_Mobile_Studio_2021.3/performance_advisor/lwi/helpers/lwi_me.py", line 657, in <module>

    sys.exit(main())

  File "/Applications/Arm_Mobile_Studio_2021.3/performance_advisor/lwi/helpers/lwi_me.py", line 604, in main

    enable_gles_debug_layer(device, args, glesLayerLibPath)

  File "/Applications/Arm_Mobile_Studio_2021.3/performance_advisor/lwi/helpers/lwi_me.py", line 225, in enable_gles_debug_layer

    device.adb("shell", "settings", "put", "global", "enable_gpu_debug_layers", "1")

  File "/Applications/Arm_Mobile_Studio_2021.3/performance_advisor/lwi/helpers/gator_me.py", line 265, in adb

    rep = sp.run(commands, check=True, shell=shell, stdout=sp.PIPE,

  File "/Library/Frameworks/Python.framework/Versions/3.10/lib/python3.10/subprocess.py", line 524, in run

    raise CalledProcessError(retcode, process.args,

subprocess.CalledProcessError: Command '['adb', '-s', '0cd7d2df9906', 'shell', 'settings', 'put', 'global', 'enable_gpu_debug_layers', '1']' returned non-zero exit status 255.

The application contains libLWI.so that is renamed to libMGD.so.

Streamline successfully connects to the application and gets the Timeline.

The system is macOS BigSur 11.6.

What is wrong?