Version `GLIBCXX_3.4.29' not found Error

Hello,

I am trying to run the fireworks example following this video: https://www.youtube.com/watch?v=HiXUh4Wx2og

First of all, the names in the video do not match with the contents of the actual examples directory. I think I found similar setup to what the video points to. (if you could help me with initial setup for the project that would be great!)

I am able to build the project successfully:

12:32:28 **** Incremental Build of configuration Debug for project fireworks_Armv8-Ax1-FVP_AC6 ****
make all
make: Nothing to be done for 'all'.

12:32:28 Build Finished. 0 errors, 0 warnings. (took 118ms)

When I add the debug configuration for the project, i try to run the project and get a following result:

Iris server started listening to port 7100
terminal_0: Listening for serial connection on port 5000
terminal_1: Listening for serial connection on port 5001
terminal_3: Listening for serial connection on port 5002
terminal_2: Listening for serial connection on port 5003
libGL error: MESA-LOADER: failed to open iris: /opt/arm/developmentstudio-2022.1/sw/models/bin/libstdc++.so.6: version `GLIBCXX_3.4.29' not found (required by /usr/lib/dri/iris_dri.so) (search paths /usr/lib/x86_64-linux-gnu/dri:\$${ORIGIN}/dri:/usr/lib/dri, suffix _dri)
libGL error: failed to load driver: iris
libGL error: MESA-LOADER: failed to open swrast: /opt/arm/developmentstudio-2022.1/sw/models/bin/libstdc++.so.6: version `GLIBCXX_3.4.29' not found (required by /usr/lib/dri/swrast_dri.so) (search paths /usr/lib/x86_64-linux-gnu/dri:\$${ORIGIN}/dri:/usr/lib/dri, suffix _dri)
libGL error: failed to load driver: swrast
X Error of failed request:  BadValue (integer parameter out of range for operation)
  Major opcode of failed request:  149 (GLX)
  Minor opcode of failed request:  3 (X_GLXCreateContext)
  Value in failed request:  0x0
  Serial number of failed request:  100
  Current serial number in output stream:  101

My suspicion is that it cannot find the GLIBCXX_3.4.29.

I do have it on my machine. I run /usr/lib/x86_64-linux-gnu$ strings /usr/lib/x86_64-linux-gnu/libstdc++.so.6 | grep GLIBCXX_3.4.29 and it shows that it is there. I suppose it is located somewhre where armds is not looking. I might have to change some path somewhere but I have no idea where and how to do that.

Thank you!