ds5 compile issues

I am sure I include all the header files, but I still got symboe XXX unresloved issues , why this happen?

Parents
  • Hi

    My name is Stephen and I work at Arm.

    Where are you seeing the unresolved symbol issues?  Do you see them in the Editor in the Arm DS IDE (indexing issues), or in the Console view when linking your project?

    If you are seeing unresolved symbols in the Editor in the Arm DS IDE, you may need to explicitly add any include paths or symbols that the IDE has not been able to automatically locate for itself.  You can resolve this by right-clicking on the project in the Project Explorer view and then selecting Properties... from the context menu. In the dialog box, select: C/C++ General > Paths and Symbols > Add... and then add any missing include paths.  Select both 'Add to all configurations' and 'Add to all languages', then click on Apply so that Eclipse will rebuild the index.

    If you are seeing them in the Console view when linking your project, then check that all the necessary objects and/or libraries are being specified on the link-line to the linker.

    Hope this helps

    Stephen

Reply
  • Hi

    My name is Stephen and I work at Arm.

    Where are you seeing the unresolved symbol issues?  Do you see them in the Editor in the Arm DS IDE (indexing issues), or in the Console view when linking your project?

    If you are seeing unresolved symbols in the Editor in the Arm DS IDE, you may need to explicitly add any include paths or symbols that the IDE has not been able to automatically locate for itself.  You can resolve this by right-clicking on the project in the Project Explorer view and then selecting Properties... from the context menu. In the dialog box, select: C/C++ General > Paths and Symbols > Add... and then add any missing include paths.  Select both 'Add to all configurations' and 'Add to all languages', then click on Apply so that Eclipse will rebuild the index.

    If you are seeing them in the Console view when linking your project, then check that all the necessary objects and/or libraries are being specified on the link-line to the linker.

    Hope this helps

    Stephen

Children
No data