netInitialize() fails with NET_ERROR_CONFIG with WiFi network interface


I'd like to use WiFi interface in my project, but I found some problem.

Before editing my project I tried to modify the "Web Server" example project.

Because the WiFi interface needs RTX5 RTOS, first of all I changed my project migrating from RTX to RTX5 RTOS following the RTX Migration Guide.

I implemented only the "Level 1 Migration - Upgrade to RTX5 on API v1", but at the moment I think it is enough for my test.

After the migration process I compiled the project and all was ok, and also the project runs without errors.

After that I integrated the WiFi interface in my project.

Starting from the "Web Server" example:

  1. I changed the Network Interface form Ethernet to WiFi
  2. I selected the device ESP8266 from the CMSIS Driver -> WiFi.
  3. I enabled the USART1 peripheral, selecting the pin P2_0 and P2_1
  4. I connect the ESP8266 to hardware via Dirver_USART#1

At the end of this integration process, it was possible to compile the project and all was ok, but when I tried to test the project I found an error during the execution of the "netInitialize()" function:

The netInitialize() function fails with the NET_ERROR_CONFIG erorr.

Could someone help me to understand if I miss something in project configuration?

In the follow you can find configurations about Network and WiFi 



More questions in this forum