STM32F429I-EVAL LCD goes blank after net_initialize() is run

I have created an LCD GUI project using MDK5 porting the STCube LCD & touch drivers into RTX RTOS task.
I have another task which blinks LEDs based on button presses, which also works.

But when I run net_initialize() my LCD screen goes blank but the task is still running and the touch input is still working as well. It is just dark.
My LED blinking\Button RTOS task still functions.
The eth_thread is running, my thread that executes net_main() is also running.
However I am not getting an IP assigned, but I can troubleshoot that later.
I enabled net_debug and can see it is trying to request an IP from the DHCP server.

But my first priority is to figure out why net_initialize is effecting my LCD.
None of the pins used for the network PHY conflict with the display in any way that I can tell.
When I run the lwip demo from ST using FreeRTOS it works fine.

If I comment out net_initialize() my LCD and touch screen work perfectly, as do my other RTOS tasks, that my button and LED tasks.

When I configured RL-NET using the configuration wizard I setup MII mode just it was in my ST lwip example, using the same pins it was in lwip. So none of those should effect my LCD.

I read an article on this site saying the PIN PI10 needs to be omitted from the PHY configuration and set back to GPIO mode. But that was causing the guy problems with Ethernet not working, and that pin is not used for the LCD or LTDC function.
http://www.keil.com/support/docs/3650.htm

I am leaning towards at least one of my port pins used for LTDC is being changed to a different configuration inside net_initialization().
Is there anyway to know what else net_intialize is doing to port pin configuration?

Does anyone have any ideas what I can look for?

Could it change the NVIC and disable the HAL_LTDC INT ISR?

Again all the tasks are running after net_initialize() is executed my LCD screen just goes blank.

More questions in this forum