mon51 with Atmel T89C51CC01

I am trying to use mon51 with a custom board based on Atmel-WM T89C51CC01 (32k Neumann RAM at 0x8000). uV2 finds the connection with the monitor and downloads my code without any error messages. After "$= 0x8000" I see my code (0x8000 LJMP STARTUP1(C:8448)). But "g, main" simply does not work, the program stucks at 0x8000. After a single step it performs the jump, but after the next one(0x8448 MOV R0, #0x7f) I find myself at 0x8000 again.
What I already tried:
(1) In T89C51CC01 one should clear ENBOOT in AUXR1 to disable FM1 from 0xf800-0xffff. So I installed mon51 to 0xe000 (install.bat 2 e0 0).
(2) I followed the steps in APP. 152
(3) I performed the RAM test recommended by Keil (MON51: TESTING VON NEUMANN MEMORY AREAS). It works fine from 0x8000 to 0xf800.

Does anyone has a board with the same controller and memory configuration? It would be good to see and try out a program that already worked on a real HW.

Thanks for any help,

Gergely


More questions in this forum