Trouble creating gator driver for Streamline

I'm working with N1SDP development board(Linux 5.1.0+ version) and trying to use Streamline with it. However, i have trouble creating gator driver (gator.ko). it is not compatible with the gator daemon (gatord). I'm wild guessing the problem comes from the Linux kernel source. I've downloaded the Linux-source(4.15. version) from the N1SDP board and tried building the gator.ko using the downloaded kernel source code on another Ubuntu host PC. Upon obtaining the gator.ko file, it is incompatible with the gatord created which in return doesn't allow us to run Streamline in Kernel Space Gator mode. Any insights on how to resolve this issue?

Thank you, 

Diane 

Parents
  • Hi Diane,

    What error are you seeing due to the incompatibility?

    As an aside, we have deprecated gator.ko as userspace gator covers most of the functionality and is much simpler to use. What functionality are you hoping to use from gator.ko, it may be available without it.

Reply
  • Hi Diane,

    What error are you seeing due to the incompatibility?

    As an aside, we have deprecated gator.ko as userspace gator covers most of the functionality and is much simpler to use. What functionality are you hoping to use from gator.ko, it may be available without it.

Children
More questions in this forum