ARM Instruction Emulator installation issue

Hello

I am trying to install ARM Instruction Emulator on Ubuntu 16.04 by running ./arm-instruction-emulator-20.0_Generic-AArch64_Ubuntu-16.04_aarch64-linux-deb.sh and keep getting the error below:


Unpacking gcc-9.2.0-runtimes-generic-aarch64-ubuntu-16.04-aarch64-linux:arm64 (9.2.0-5) ...
dpkg: dependency problems prevent configuration of gcc-9.2.0-runtimes-generic-aarch64-ubuntu-16.04-aarch64-linux:arm64:
gcc-9.2.0-runtimes-generic-aarch64-ubuntu-16.04-aarch64-linux:arm64 depends on libc6-dev.

Then I tried to install libc6-dev with "sudo apt-get install -y libc6-dev" but running into unmet dependencies:

Reading package lists... Done

Building dependency tree

Reading state information... Done

libc6-dev is already the newest version (2.23-0ubuntu11.2).

You might want to run 'apt-get -f install' to correct these:

The following packages have unmet dependencies:

 gcc-9.2.0-runtimes-generic-aarch64-ubuntu-16.04-aarch64-linux:arm64 : Depends: libc6-dev:arm64 but it is not installable

E: Unmet dependencies. Try 'apt-get -f install' with no packages (or specify a solution).

Can you let me know which version of libc6-dev I should install and how to resolve the unmet dependencies?

Thank you very much for your help,

Kim

More questions in this forum