AXI transaction failure

Hello everyone,

I'm pretty new to axi and i still try to figure things out. I'm using Zybo device and created a custom ip with a master and a slave interfaces. I have create design as you can see in the below. Write transaction is work however, read transaction does not. 

However i have test it by using AXI Verification IP and following this tutorial . It worked as you can see below. After the design below, i put interconnect between VIP and myIP, it also worked. I believe problem is the PS. I really appreciate if you help me.

  

Thank you very much.

  • Hi Kaya,

    I came to the same question as yours. My AXI peripheral ip M00_AXI to PS S_AXI_GP0 connection is not working. But it could pass through AXI verification IP simulation. Did you figure it out? Any idea what's might be the cause. I also think the PS should be responsible for it, but don't know what needs to be done. Thanks for your time, any prompts will be appreciated. 

More questions in this forum