uvision5: failed to execute ' '

Hi, I have now troubles in debug process.

I'm using renesas RA6M4 and have just created a simple project to run to see if I can debug without any problems.

However, as the console says, Error: failed to execute ' ' occurred and I have no idea what it means.

I guess some settings are wrong, but I cannot find the cause.

Could anyone tell me the cause of this error?

  • Let me add more information.

    I was able to build the project, but when I tried to download the code to flash, I got those errors.

  • Hello! I never used the Renesas RA6M4 devices. But when looking into this Application note KAN330, there is still no flash programming algorithm in the RA_DFP 3.1, as far as I can see. So clicking on the "Flash Download" icon in uVision will not work. Most likely the "Error: failed to execute ' '" results from the fact, that in "Options for Target ... -> Utilities" the option "Use External Tool for Flash Programming" is selected, and no tool was specified.

    So, not sure, what debug adapter you use, but according to the KAN330 only the (onboard) JLINK can probably be used for flashing. And that should do it by just starting the debug session, as the JLINK should program the flash automatically when uVision tries to load the data to the execution addresses.

    If still unsure, please also contact Renesas what other options currently exist to program the and along with that, demand them to provide flash programming algorithms in the DFP, that can be used by the IDE, like MDK/uVision.