ARM Keil Studio Cloud - seems to be very broken


I figured out some Issues with Keil Studio - Keil Studio ( (for more KS).
* When I tried to delete a folder, the folder not disappear. It disappear after reload the page.
* After few compilations the KS absolutely ignore all changes in the code. When I hit build button, the KS immediately export .bin file in its latest state without latest changes in the code. It not depend if it is a variable, a macro, an include or change version of MbedOS. Also not depend on target (Nucleo-F767ZI and Disco-F746) or MbedOS (6.8 and 6.11) version. The clean build must be used every time!
* Another strange issue is when the KS after some time, maybe 30-60 min, automatically downgrade some libraries. For example I imported a program with MbedOS 6.10 and with LVGL 7.11. I updated them both to the master (6.11 and 8.0) and after some time were both libraries on version of imported state (2-4 times today).

I worked with this tool when it was Mbed Studio Online, porobably in closed beta, at summer 2020. How I remember Its main issue, for basic usage, was unstable intellisense but this is pain.

Windows 10 PRO 64bit with MS Edge (91.0.864.41).

MbedOS 6.8-6.11 with few ST targets.

BR, Jan