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STM32CubeIDE



One tool for all your STM32 development

Chipset / Board

Configuration

Code

Development

Validation

Debug
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Free multi-platform development tool

Free for Commercial Development Eclipse/GCC Based Multi-OS Support

FREE
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TO-DO

Create a STM32CubeIDE project for GPIO toggle with Project Name : FAE_name

OR

Open below project 

Repository\STM32Cube_FW_U5_V1.2.0\Projects\NUCLEO-U575ZI-Q\Examples\GPIO\GPIO_EXTI

• Add the GPIOC->ODR  and IDR register in the favorite list 

• Give the list name as “CompanyName_ FaeName”

file:///C:/Users/solankik/STM32Cube/Repository/STM32Cube_FW_U5_V1.2.0/Projects/NUCLEO-U575ZI-Q/Examples/GPIO/GPIO_EXTI


• Favorite lists

• Focus on a subset of peripherals and 

registers!

• Live update

• Live channel provides ~5Hz live update

• Log export

• Troubleshoot your peripheral configuration by 

comparing log-files

SFR-view – 3 use cases
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Available in STM32CubeIDE 1.11.x or 

later



1. Right-click on a node and click Add as favorite…

• Peripheral

• Register

• Single bit.

Favorite list(s)

2. Select a List name or type

in the name of a new List

3. Display only your favorites



Live updates

1. Right-click on register-level → Toggle live update

• Only applicable at register-level since

debugger always reads 32-bits.

2. The “google” icon indicates

that live-update is enabled

3. Register values are updated 

“live” while target is running



1. Select the Export scope

• All registers?

• Or just a favorite list?

Log export and compare

2. Logs are saved in SFR_export

• Named by incremental number

3. Compare two log-files

• Right-click → Compare with → each other



• Cyclomatic complexity is a 

measurement which give the 

possibility to determine the stability 

and level of confidence in a program.

• The new view show the level of 

complexity for each function.

Add support for cyclomatic complexity



STM32CubeIDE



• Enable SWO via the STM32CubeMC perspective and re-generate the code.

Adding SWO pin
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• Steps:

• Enable SWV Ftr:

• Step 1: Go to Debug

• Step 2: “Debug Configurations” 

Enable SWV in the debugger settings(1/2)
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Steps contd:

• Step 3: Go to “Debugger” 

tab

• Step 4: Enable SWV

• Step 5: SWV tracing 

requires manually setting 

the Core Clock to the 

correct value, 4 MHz in 

our case

• Click “Apply” -> “Close”

Enable SWV in the debugger settings (2/2)
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4
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• Using Data Trace & Live Watch

• Using Data Trace Timeline Graph

• printf() redirection

• Timing measurement

• Exception Trace Log & Timeline Graph

SWV: features explored
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STM32CubeIDE

SWV: Data Trace & Live Watch
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• Data Trace: 

• To watch variables live

• No need to stop on a breakpoint OR Halt execution

• Monitor the memory reads and writes of particular variables

• Can be used to detect unexpected RAM access.

SWV: using Data Trace



• Start Debug session

• Go to Window -> Show View -> SWV  and click SWV Data Trace

• Click on “Configure Trace” button to open the Serial Wire Viewer settings

Enable SWV Data Trace
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• Step 1: Enable “Timestamps”

• Step 2: Enable Trace Comparator 0

• Step 3: Add the variable 

name/address to be traced 

(LoopCounter)

• Step 4: Select “Write” in the Access 

list (only monitor Write access)

• Step 5: Select “Data Value” to be 

logged, click OK

• Note: Keep other trace events 

disabled to avoid chances of 

overflow in the SWO line

Serial Wire Viewer settings
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• Step 1: Click on “Start Trace 

Button”

• Start Execution

• Step 2: Observe the Data live on 

the “SWV Data Trace Console”

• Live Watch

• History

• Timestamps(~101 ms delay between 

each Write in our Case)

SWV: Using Data Trace
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STM32CubeIDE

SWV: Data Trace Timeline Graph
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• Used for Graphical Data plot of variables in real-time

• An “Oscilloscope style” data plot graph

• Pots the Graph of Data Vs Time OR Data Vs Clock Cycles

• Also allows to save the graphs as images to study later

SWV: Using Data Trace Time Graph



• Start Debug session

• Go to Window -> Show View -> SWV and click SWV Data Trace Timeline Graph

• Click on “Configure Trace” button to open the Serial Wire Viewer settings

Enable SWV Data Trace Timeline Graph
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• Step 1: In the “Data Trace” settings, 

add Comparator 1

• Step 2: add “Sensor_Data” and also 

set the other fields of Access, Size, 

Data Value as shown here.

Configure SWV settings
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• Click on “Start Trace” 

button

• Start Execution

• You shall now start 

seeing some graphs 

being plotted in the 

console

• Note: Keep other trace 

events disabled to avoid 

chances of overflow in 

the SWO line

SWV: Using Data Trace Timeline Graph
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• Few Sample Graphs 

generated

• Multiple Data variables can 

be plotted

• Color coding to identify 

different variables

SWV: Using Data Trace Timeline Graph
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STM32CubeIDE

SWV: printf() redirection
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• Typically, we use printf() messages sent via UART to 

troubleshoot the application during run time

• SWV can be used for printf() re-direction

• Debug messages are sent to a “Console” window in the 

debugger using the Serial Wire Output (SWO) pin

• No need for a USB or UART cable

SWV: printf() redirection



• Include stdio.h library to declare 

printf functionality

• Add code to print messages 

• To redirect printf() to SWO pin

• Redefine _write() function to send data 

to SWO pin using ITM_SendChar() 

function

• Weak _write() included in syscalls.c file 

• Same technique can be used to print to 

USART pins

Redirect printf() to SWO pin
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/* USER CODE BEGIN Includes */
#include <stdio.h>
/* USER CODE END Includes */

/* USER CODE BEGIN 4 */

int _write(int file, char *ptr, int len) 

{

int DataIdx;

for(DataIdx=0; DataIdx<len; DataIdx++)

{

ITM_SendChar(*ptr++);

}

return len;

}

/* USER CODE END 4 */



• Start Debug session

• Go to Window -> Show View -> SWV and click SWV ITM Data Console

• Click on “Configure Trace” button to open the Serial Wire Viewer settings

Enable SWV ITM Data Console
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• Enable Channel 0 from the 

ITM Ports

• Note: Keep other trace events 

disabled.

Configure SWV settings
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• Click on “Start Trace” 

button

• Start Execution

• View printf() messages in 

the “SWV Data Console”

SWV printf() redirection
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STM32CubeIDE

SWV: Timing Measurement
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• Used to measure execution timings for 

a process/function

• Step 1: Add ITM Stimulus Port register definition 

MACRO to your source code (main.c), which 

allows us to write to an ITM Port

• #define ITM_Port32(n)   (*((volatile unsigned long 

*)(0xE0000000+4*n)))

• Step 2: Write 2 different values to the ITM Port 31

before and after the desired functions

• ITM_Port32(31) = 1;

• ITM_Port32(31) = 2;

SWV: Timing Measurement
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• Start Debug Session

• Go to Window -> Show View -> SWV and click SWV Trace Log

• Click on “Configure Trace” button to open the Serial Wire Viewer settings

Enable SWV ITM Data Console
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• Enable Timestamps

• Enable Channel 31 *only* 

from the ITM Ports

• Note: Keep other trace events 

disabled to avoid chances of 

overflow in the SWO line

SWV: Timing Measurement

36



• Click on “Start Trace” button

• Start Execution

• Observe the Trace values & 

timestamps in the “SWV 

Trace Log Console”

SWV: Timing Measurement
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STM32CubeIDE

SWV: Statistical Profiling
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• Statistical profiling feature of the SWV provides a way to quickly analyze the 

performance of the application code and optimize speed.

SWV: Statistical Profiling



• Start Debug Session

• Go to Window -> Show View -> SWV and click SWV Statistical Profiling

• Click on “Configure Trace” button to open the Serial Wire Viewer settings

Enable SWV Statistical Profiling
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• Enable PC Sampling and 

click ok

• Note: Keep other trace events 

disabled to avoid chances of overflow 

in the SWO line

Configure SWV settings
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• Click on the Start Trace 

button.

• Execute the code.

• Halt the execution in order to 

see a statistical profile of the 

application when it was 

running at that particular time 

frame.

Start Statistical Profiling view
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STM32CubeIDE

SWV: Exception Trace Log
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• Start Debug session

• Go to Window -> Show View -> SWV and click SWV Exception Trace Log

• Click on “Configure Trace” button to open the Serial Wire Viewer settings

Enable SWV Exception Trace Log
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• Enable Timestamps

• Enable EXETRC: Trace 

Exceptions 

• Click OK

• Note: Keep other trace events 

disabled to avoid chances of 

overflow in the SWO line

Configure SWV settings
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• Click on Start Trace button

• Execute the code to see exception logs

• Click on the statistics tab to the exception profile.

SWV: Exception Trace Log
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STM32CubeIDE

More IDE Options
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• To generate binary (.bin) and hex (.hex) output files

IDE options: Good-to-know

• Go to Project >> Properties >> 

C/C++ Build >> Settings >> 

Tool Settings >> MCU Post 

build outputs

• Enable these 2 checkboxes to 

generate binary (.bin) and hex 

(.hex) output files



IDE options: Good-to-know
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• To check the Flash and RAM 

consumption : Build Analyzer -> 

Memory Regions

• To check stack consumption of 

individual functions: Static Stack 

Analyzer -> List



• STM32CubeIDE supports below 

Debuggers

• ST-LINK (GDB server)

• ST-LINK (OpenOCD)

• SEGGER J-LINK

IDE options: Good-to-know
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STM32CubeMonitor



Several monitors



Introducing STM32CubeMonitor

Real-time variable monitoring

during application runtime

Flexible graphical visualization

Direct support of the Node-RED® 

open community
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Key features

Monitoring application variables during runtime

• Non-intrusive tool to follow application behavior without 

interruption

• Real-time analysis to finetune application configuration

Drag & drop creation of dashboard UI

• Large choice of graphical components (gauges, bar graphs,

plots...)

• Customize settings. No need for programming.

• Multi-OS tool: direct support of PC, tablets and smartphones

• Remote monitoring

Graphical visualization on any display
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Data visualization

Dashboard mode to visualizeDesign mode to create

Build and edit the logical data flow and graphical 

rendering of the custom monitoring UI.
Use the monitoring UI built previously and visualize

locally or remotely.
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Open community

Unlimited possibilities

Large choice of ready-to-use nodes to easily expand

STM32CubeMonitor default palette.

Direct support of Node-RED community

Flow-based visual programming for connecting

hardware devices, APIs and online services (a flow

is composed of connected nodes: input, output,

function etc.)
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• STM32CubeMonitor performs data acquisition by reading in the target MCU 

memory though ST-Link and SWD/JTAG connection.

• The elements involved are :

• STM32 JTAG/SWD access port

used to connect the MCU debug block to ST-Link.

• ST-Link device.

• STM32CubeMonitor software.

• All the MCU address space is accessible.

Presentation of the tool
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Let's start with STM32CubeMonitor



• Let’s start from this point

• Please plug in your STM32 board to

your PC

• Launch STM32CubeMonitor

• STM32CubeMonitor starts in 

design mode

• The basic flow is displayed

59

The design mode



• One TX path from PC to probe

• STARTAcquisition

Messages are sent on the ST-Link:

➢ "Read sequencially myVariables“

• STOPAcquisition

No more messages are sent on the ST-Link

• One RX path from probe to PC

• MyVariables are received and displayed on

the chart.

Flow structure
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• The MCU and its MCU debug block

use addresses

• Humans prefer names

• PC software also!

➢ The nodes “myVariables” manages the

translation

Name and address

AddressesNames

NamesAddresses

61



The dashboard mode 

• The widgets seen on the flow are displayed on the dashboard.

• 3 Buttons

• START, STOP, CLEAR

• Chart
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Read variables from MCU RAM memory



• Let’s access to some variable of the firmware

• The code defines the type of “basicCounter”

➢ Unsigned 16-bit

• The code increment the “basicCounter” every 500ms

64

Variable name



• The variable names are in the elf executable file

• generated during the project build in STM32CubeIDE

• STM32H735-DK.elf

• .out and .axf extensions also supported

Get the names from elf
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• Add new exe-config...
1. Double-click on “myVariables”

• The variables node properties are displayed

2. Click on the pen of “Executable"

1

2

Get the names from elf
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• Create the exe-config
1. Give a name to the configuration

2. Fill “Folder” with the folder containing the elf file

➢ C:\STM32H7EcoWS\HandsOn_01

3. Select the elf file from the drop-down list

➢ STM32H735G-DK.elf

4. Click in Update

1

2

3

4

Get the names from elf
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• Select the variables in the

“Variable List”
1. Select “basicCounter”

2. Click on “Add”

• Adds the configuration to the “myVariables”

1

2

Get the names from elf 
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• The variable list is configured
• Name

➢ basicCounter

• Address

➢ 0x2400803C

• Type

➢ Unsigned 16-bit

1. Click on “Done”

1

Get the names from elf
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• Save the flow
• A blue point on “myVariables” shows that the

configuration has been modified.

1. Click on “Deploy”

1

Get the names from elf

70



• Launch the dashboard
• “Successfully deployed” is displayed

1. Click on “Dashboard”

1

Monitor and visualize
read in MCU RAM memory
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• Launch the acquisition
1. Click on “STARTACQUISITION”

➢ “basicCounter” is sequentially read from the

MCU RAM memory

➢ “basicCounter” is regularly incremented

1

Monitor and visualize
read in MCU RAM memory
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• Stop reading the variable
1. Click on “STOP ACQUISITION”

• The times and values can be visualized

2. Click the “Show Points” checkbox

➢ ‘basicCounter” is incremented by 1

➢ “basicCounter” is incremented every 500ms

➢ Use the zoom for more precision

➢ Zoom or Brush is selectable.

➢ In zoom mode, it’s possible to zoom on the curve

using the mouse to select a zone.

21
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Monitor and visualize
read in MCU RAM memory



Write variables to MCU RAM memory



Add a widget

• Currently, no way to write a value to a variable.

➢ The “write panel” widget in the node palette will be used
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Add a widget

• Drag & drop the “write panel” in the flow editor

1. Click on the “write panel” node and hold the button down

2. Drag the “write panel” node to the flow editor

➢ “myprobe_Out” can be dragged a bit further

1 2
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Add a widget

• Set the “write panel” properties

• A red triangle is visible on the “write panel” node

➢ Properties are not configured

➢ The”write panel” widget will not be added to the dashboard!

1. Double-click on the “write panel”

➢

➢

➢

➢ “Group” has been set automatically as only one exists
UI group on the dashboard = Chart 

Tab = Home

➢ Several groups can be created on the dashboard

➢ Several flows can be opened in the flow editor

The dashboard will then have several tabs with several UIs

2. Click on “Done”
➢ The name is optional

1

2
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Add a widget – done!

• Launch the dashboard
1. Click on “DEPLOY”

2. Click on “Dashboard”

• The write panel widget has been added

• Visual programming

• A drag & drop and some clicks

• Let’s add a variable in the panel
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Add a variable

• Add a link with “myVariables” to populate the write panel

1. Put the mouse on the input of the “write panel” node

➢ The input point is displayed in orange
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Add a variable

• Add a link with “myVariables” to populate the write panel

2. Click and drag to the output of “myVariable”

➢ Hold the mouse button down until the output point is displayed in orange

➢ The link is done

➢ The list of variables will appear in the write panel as soon as the “STARTACQUISITION” button is clicked
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Activate the “WRITE” button

• Add a link with “myProbe_Out”

1. Drag a link between the output of the “write panel” and the input of “myProbe_Out”

➢ The link is done

➢ A click on the “WRITE” button will produce a message sent on the ST-LINK:

➢ “Write the selected variables“
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Monitor and visualize
write in MCU RAM memory

• Launch the acquisition
1. Click on “DEPLOY”, then “DASHBOARD”

2. Click on “STARTACQUISITION”

➢ “basicCounter” is in the write panel list

2
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Monitor and visualize
write in MCU RAM memory

33

• Write to the basicCounter variable
1. Write a value in the text box beside

“basicCounter” name

2. Click on “WRITE”

➢ “basicCounter” value is changed to the written

number.

1

2
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Read or Write a peripheral register



• All the MCU address space is accessible.

• But some addresses don’t have a variable name in the elf file.

➢ Registers

• How to read/write an address without a name?

• Let’s take the example of an I/O port

Read/write to an address
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• The GPIOC base address is 0x58020800

• The ODR register has the offset 0x14

➢ The lowest byte of ODR register is at 0x58020814

From RM0468
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Add the address

• Add the address in the variable list
1. Open “myVariables” properties

2. Click on “Add custom variable”

3. Fill the fields

• Name

➢ GPIOC_ODR

• Address

➢ 0x58020814

• Type

➢ Unsigned 8-bit

4. Click on “Done”

• The name is mandatory

➢ For humans

➢ For STM32CubeMonitor software

1

2

3

4
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Monitor and visualize
Read in MCU register fixed address

• Launch the acquisition
1. Click on “DEPLOY”, then “DASHBOARD”

2. Click on “STARTACQUISITION”

➢ “basicCounter” is displayed

➢ The GPIOC_ODR is also displayed

2
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• How to configure the flow

➢ How to connect to the STM32 MCU board through ST-Link

➢ How to get the variable names from the executable file

• How to access to the STM32 memory

➢ Read / Write using the variable name

➢ Read / Write using the address

• All the STM32 address space is accessible

• How to add a widget to the dashboard

➢ Drag & drop on the flow editor

➢ Insert in the flow

• Make the connection with previous and next node

We have seen...
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STMH72x/3x Demo flow



• An example of customization

➢ More widgets

➢ But same concepts

• Let’s import the flow

STMH72X/3X Demo flow
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Disable a flow

• Disable the “Basic_Flow”
1. Double-click on the “Basic_Flow” tab

2. Click in Enabled

➢ It is changed to disabled

3. Click on Done

➢ The “Basic_Flow” tab remains in the flow editor but no “Home” tab will be accessible in the dashboard.

1

2

3
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• Please click on “DEPLOY”
• If not closed and acquisition not stopped, the

dashboard is disabled and the ST-Link is relaxed.

• Open the menu and select import
1. Click on the menu

2. Click on “Import”

Import a flow

2

1
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Import a flow

• Import from a file
1. Click on “select a file to import”

2. Open the STMH72x/3X Demo flow

➢ In C:\STM32H7EcoWS\STM32CubeMonitor

➢ STM32H72x-3x WS.json

1

2
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Import a flow

• Import from a file
1. Click on “Import”

1
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Import a flow

• The STMH72x/3X Demo flow 

is now visible in the flow editor

• More nodes, more links, but…
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Same flow structure

• One TX path from PC to probe

• But 3 variable lists

• Only 1 variable can be written in the write panel

• The sampling frequency is slow or fast

• And a new way to write in MCU RAM

memory

➢ 3 switch widgets allows to write to 3 variables

➢ But the same message to the ST-Link probe 

than the write panel

➢ “write this value at that address”

➢ 0 for switch OFF, 1 for switch ON
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Same flow structure

• One RX path from probe to PC

• 3 variable processing nodes

➢ Paired with each variable list

• Again 1 chart but also other output widgets

➢ Text, gauge, LEDs

• In between, selection nodes

➢ Select which variable is displayed on which widget

➢ A variable can be displayed on several widgets

➢ Several variables can be displayed on a widget

➢ More customization but...

➢ Nothing more difficult than "Basic_Flow"
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• Set ST-Link (Monitor to MCU)
1. Double-click on “H7Demo to MCU”

2. Click on the pen of “Probe Config”

3. Select the ST-Link probe

4. Click on “Add”

5. Click on “Done”

• Set ST-Link (MCU to Monitor)
• Do the same for “MCU to H7Demo”

Prepare the flow
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Launch the dashboard

• The dashboard displays

• Known widgets

• 3 Buttons

• START, STOP, CLEAR

• 1 chart, 1 write panel

• New widgets

• 1 gauge

• 3 text fields

• 3 switches and LEDs
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Variables at fixed address

• Other firmware will be downloaded to 

the board for HandsOn2 and 

HandsOn3

• But the same variables will be used.

➢ Variables in a structure at fixed address

• H7Demo - 0x24000000 to 0x24000008

➢ Reads and writes at the same addresses

➢ No need to update the elf file
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Launch the dashboard

• The current firmware is a 

simulation firmware
• The same logic but only dummy actions

• Example of the cache switch

• When HandsOn2 firmware will do

➢ The Perf varies because of cache on/off

• The current firmware does

➢ The cache is always off

➢ The Perf is dummy

H7Demo.Status_CacheH7Demo.Cmd_Cache
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Remote monitoring

STM32 STLINK probe Gateway

SWD USB

Dashboard

Native support of multi-format displays
Dynamic layout of dashboard UI on PCs, 

tablets, smartphones.

Remote data acquisition with web

server technology
Monitor across a network with a web browser

User 

Application
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• STM32CubeMonitor is a non-intrusive tool to monitor a running application
➢ Uses the MCU debug bloc and the SWD protocol

• STM32CubeMonitor is easily customizable.

• We have seen the basics:
• How to configure the flow

• How to access to the STM32 memory

• How to add widgets to the dashboard

➢ You are ready to design your own dashboard

Conclusion
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Going further - Documentation & Links



• The help is directly accessible through 

the menu

• Allow to find information to guide the user

➢ ST Community

➢ STM32 MCU wiki

To go further
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Resources and useful links

Read our technical documentation on STM32CubeMonitor

Share use cases with STM32 community

Visit our STM32CubeMonitor web page

Watch our Getting started webinar (video)

Read our latest blog post

107

https://wiki.st.com/stm32mcu/wiki/STM32CubeMonitor_tool_suite_overview
https://community.st.com/s/topic/0TO0X000000x33lWAA/stm32cubemonitor
https://www.st.com/content/st_com/en/products/development-tools/software-development-tools/stm32-software-development-tools/stm32-performance-and-debuggers/stm32cubemonitor.html
http://www.st.com/embedded-cubemonitor
https://blog.st.com/stm32cubemonitor/


STM32CubeProgrammer



From multiple utilities 
to STM32CubeProgrammer

109

– bootloader interface of UART

– IAP, ISP

– debug interface of JTAG/SWD

internal flash, ext. memory, 

option byte

STVP

Flash 

Loader

ST-Link 

Utility

DFUSe

– upgrade STLINK

– bootloader interface of USB

– IAP, ISP



Command Line Interface
for Scripting

All-in-one programming software tool

Option Bytes 
Program & Upload

Bootloader Interface Support
(USB, UART, SPI, I2C, CAN)

STLink Direct Support
(JTAG, SWD)

Multi-platform
(Windows, Linux, macOS)

Trusted Package Creator
(secure programming)

API DLL 
for Custom Integration

Automatic Mode

Intuitive GUI

Internal/External 

Flash Services
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ST-LINK

USB

UART

Supported interfaces
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CAN

SPI

Supported interfaces

I2C
112



Memory & file editing

Read Edit

Download Verify
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Memory & file editing

Download 
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Full chip erase

Erase entire 

chip memory



Erasing & programming

File programming 

(.bin, .hex, .srec, .elf)

Automatic Mode

Sector erase



External loaders

Program External 

memory



Option Bytes

Read & Program 

option Bytes



OTP MPU

OTP 

programming



MCU core

Manipulate register



Hard Fault Analyzer
STM32CubeProgrammer



Overview
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STM32CubeProgrammer

ST-LINK

CLI GUI

Memory

CPU

STM32 MCU

STM32 MCU

Hard Fault Analyzer



Hard Fault Analyzer UI

1

3

4

2

5
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• Device : STM32L476 Nucleo Board

• Interface : STLINK via SWD

• Scenario : Division By Zero from an EXTI Handler

• Fault type : Usage Fault, Devide by 0 error

(DIVBYZERO)

Demo 1: Division By Zero

124

EXTI15



• Device : STM32U574ZI-Q Nucleo Board

• Interface : STLINK via SWD

• Scenario : Read a non accessible memory region

• Fault type : Bus Fault, Precise data access error

(PRECISERR)

Demo 2: iIlegal READ
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Register Viewer



• Functionalities:

✓Visualize all the MCU and core registers.

✓Modify the MCU registers values.

✓Save MCU registers values into a log file.

Overview

127

Note: Access using SWD/JTAG.

CLI Command: 
-regdump <file_path.log> [choice=<number>] 





Register Viewer

Demo



Serial Wire Viewer



Overview

131

• Display printf data sent from the target

• Available through the SWD interface

• User application should configure the ITM

and SWO pin to generate the trace.

• Less intrusive compared to UART/VCP.

CPU 

Core
ITM ST-Link

SWO

Target

SWV



• Specify target system clock frequency.

• Select the corresponding stimulus port

at which the application is sending data.

• Click on the start button.

• Optionally generate a .log file.

• Optionally enable colored traces output.

• Feature available on both CLI and GUI.

Functional description



STM32Cubeprogrammer v2.14.0 release information
•Updated the support for the entire STM32H5 series:

– Debug authentication with password or certificate
– Authentication key provisioning
– Key generation
– Firmware encryption and signing
– Certificate generation
– SFI support, secure manager install, and module install/update

• Added support for microcontrollers in the STM32L5 series and STM32WL series:
– SFI integrity check

• Updated support for the STM32U5 series:
– SFI support for the STM32U535/545, STM32U575/585, STM32U595/5A5, and STM32U599/5A9 product lines

• Added support for the STM32U5Fxxx and STM32U5Gxxx microcontrollers:
– SFI support: user interface and command-line interface
– SFIx support:

◦ Via debug: user interface and command-line interface
◦ Via bootloader: command-line interface only

Refer to the STM32CubeProgrammer software description user manual (UM2237) for details.
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STLink portfolio
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From ST-Link V2 to STLink-V3

ST-Link V2 STLink-V3

ST-LINK/V2-1

ST-LINK/V2

ST-LINK/V2-ISOL

135Why upgrading : STLinkV3 has better performances, more features, and mods. 

STLINK-V3SET

STLINK-V3MODS

B-STLINK-ISOL

STLINK-V3MINIE

B-STLINK-VOLT



STLINK-V3 tools enable developers 
to debug / program with more efficiency

136

Easier

Faster

More Flexible



Energy profiler ****

Voltage adaptation

1.65-3.3 V
*** ***

Virtual COM port/ 

USB bridge
** ** **

Debug/Program *

STLINK evolution

STLink/V2
B-STLink-VOLT

STLink-V3MINIE

STLink-V3SET

STLink-V3MODS

137

STLink-V3PWR



…to address a large diversity of needs
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Adapter board

Easy addition of 

multi-path bridge 

and 

debug connector 

formats

USB to :

UART

SPI

CAN

I2C

:

GPIOs

Connector formats :

STDC-14

JTAG-20

STLINK-V3SET



STLINK-V3SET a scalable debugger/programmer 
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STLINK-V3SET

• Performance boost (vs STLink/V2)

• Optimized algorithms

• USB 2.0 High Speed interface

Easier

• JTAG / SWD / SWV (STM32 debug)

• SWIM (STM8 debug)

• Drag and drop flash programming

• Virtual COM port

Faster

More flexible

• Extension boards

• Multi-path bridge (through adapter board)
35$



STLINK-V3SET anatomy 140

STDC-14

(JTAG / SWD

+ VCP)

USB 2.0

High-speed

STDC-14

(JTAG / SWD

+ VCP)

UARTSPI

SPI / UART / 

I2C / CAN / 

GPIOs

SWD

SWIM

Virtual COM 

Port (VCP)

Base board Adapter board

STM32F7

mcu

JTAG-20



STLINK extension boards
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Voltage adaptation 

• 1.65 – 3.3 V voltage adaptation for debug / virtual 

COM port / bridge signals

• Compatible with STLINK-V3SET casingB-STLINK-VOLT

B-STLINK-ISOL

20$

Galvanic isolation & Voltage adaptation 

• 1.65 – 3.3 V galvanic isolation and voltage adaptation 

for debug / virtual COM port / bridge signals

• Compatible with STLINK-V3SET casing

40$



• Virtual COM port

• Tiny size 15 x 42 mm

• 3D printer files for slim casing

Small STLINK-V3MINIE makes big difference

142

11$

More performance at lower price 
(vs STLink/V2)

• JTAG / SWD / SWV debug interfaces

• USB Type-C High Speed interface

STLINK-V3MINIE

Facilitate in-the-field FW update

Direct support of power-constrained 

IoT products

• Voltage adaptation 1.65-3.3V



STLINK-V3MODS, a ready-to-use module 
for your custom boards
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STLINK-V3SET

STLINK-V3MODS

8.25$

• Footprint 15 x 30 mm

• Price below 9$

Performance boost 
(vs STLink/V2)

• JTAG / SWD /SWV debug interfaces

• USB 2.0 High Speed interface

Small size, small price

Multi-path bridge

• Virtual COM port

• Drag and drop programming

• USB to UART / SPI / I2C / CAN / GPIOs



STLINK comparison
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Features STLink/

V2

STLink-

V3MODS

STLink-

V3MINIE

STLink-

V3SET

B-STLink-

ISOL

STLink-

V3PWR

Mcus supported
STM32

STM8
STM32 STM32

STM32

STM8
STM32 STM32

Casing *
(on-board

module)
STL file *

V3SET 

extension *

USB
Full Speed 

(12Mbit/s)

High Speed 

(480Mbit/s)

High Speed 

(480Mbit/s)

High Speed 

(480Mbit/s)

V3SET 

extension

High Speed 

(480Mbit/s)

SWD max 

read data rate
150 kByte/s 800 kByte/s 800 kByte/s 800 kByte/s 475 kByte/s

Virtual COM port No 16 MHz 16 MHz 16 MHz 10 MHz 12 MHz

Multi-path bridge No * No * * *

Target voltage 3.3V 3.3 V 1.65-3.3 V 3.3 V 1.65-3.3 V 1.6-3.6 V

Energy profiler *

Price 21$ 8.25$ 11$ 35$ 40$ 95$



Software support and Product references
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IDE toolset

EWARM

IDE toolset

MDK-ARM

STM32CubeIDE

STM32CubeMonitor

STM32CUBEMON

STLINK-V3MINIE / V3MODS

STLINK-V3SET / V3PWR

STM32CubeProgrammer

STM32CUBEPROG



STLink-V3Power
energy profiling tool



Dvt tools

100nA / 50mA

STM32L0, L4

STM32WB

nA up to 500mA

All STM32 MCUs

300nA / 150mA

STM32L0, L4, 

STM32L5, U5,

STM32WB, WL

…Enables energy profiling of any STM32 MCU

STLINK-V3 PowerEnergy meterPower shield

Target MCUs

Dynamic current

ranges

X-NUCLEO-LPM01A STM32L562E-DK STLINK-V3PWR



Optimize the energy efficiency of STM32 mcu applications
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Measure dynamic current consumption with high 

accuracy

Debug code in sync with energy consumption

measurements

Programmer with multi-path bridge

Visualize energy consumption with

STM32CubeMonitor-Power SW tool

Direct support of Keil and IAR IDEs for power 

profiling

STLINK-V3PWR

95$



STLINK-V3PWR powerful easy-to-use energy profiler
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Current measurement

with wide dynamic range 
nA-500mA 

High accuracy (up to +/-0.5%)

Resolution up to 2nA

Programmable output 

voltage source 
1.6 - 3.6V (under up to 2A)



STLINK-V3PWR overview

Multi-path bridge 

USB to 

UART / SPI / I2C / 

CAN / GPIOs

Debugger / Programmer

SWD / JTAG (STDC14 connector)

Virtual COM port

Debug code in sync with 

power consumption 

measurements

Programmable voltage 

supply for target

USB Type-C

high-speed interface
-Simultaneous access of 

CubeMonitor-Power and IDEs

-Fast programming with 

CubeProgrammer



Visualize power data with
STM32CubeMonitor-Power tool
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Display

Analyze

Benchmark

• Graphical rendering in real-time (up to 100 kSPS)

• Acquisition log over large period of time

• Intuitive zoom and navigation into energy

consumption data

• Fast computation of EEMBC ULPMark-CP 

scores



Software support and Product references
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IDE toolset

EWARM
From release v9.32.2

IDE toolset

MDK-ARM
From release v5.38a

STM32CubeIDE From release v1.12

STM32CubeMonitor-Power

STM32CUBEMONPWR
From release v1.2

STLINK-V3PWR

STM32CubeProgrammer

STM32CUBEPROG
From release v2.13



Configuration
Code 

generation
Code editor Debug

Simple 

Programming

Advanced 

programming
Monitoring 

Main feature Main feature

Available thanks 

to embedded 

STM32CubeMx 

Features

Available thanks 

to embedded 

STM32CubeMx 

Features

Main feature Main feature
Programming  

of the flash 

Limited 

monitoring via 

SWD + IDE 

feature 

Main feature

Main feature

Please refer to 

the slides for 

details

Main feature 

Advanced 

monitoring  

Summary slide

153



AI solutions



What is AI?

155

Any technique that enables 

computer to mimic human behavior

Subset of AI. Algorithms and 

methodologies that improve over 

time through learning from data

Subset of ML. Learning algorithms 

that derive meaning from a huge 

amount of data, by using a 

hierarchy of multiple layers that 

mimic the neural networks of the 

human brain1950 1960 1970 1980 1990 2000 2010 2020

Artificial Intelligence (AI)

Machine Learning (ML)

Deep Learning

Early Artificial 

Intelligence stirs excitement
Machine Learning 

begins to develop

Deep Learning breakthroughs 

drive AI boom

The evolution of AI



A new way to add environment awareness 
to your products 

156

Machine Learning
Rules learnt from real-world data

Standard programming 
Handcrafted rules based on experience

Input Data Input Data

▪ Requires domain expertise to code

▪ Need to rewrite if environment evolves

▪ Generate code from real-world observations

▪ Re-learn from data if environment evolves

Create more robust software using Machine Learning on STM32

Procedural 

algorithm

Desired output from the system

Desired output 

from the system

General ML model trained 

for the specific problem



White goods

Smart control

Self-driving Cars

Environment sensing

Smart Buildings

Energy saving

Personal electronics

Activity recognition

Drones

Flying & landing

Smart Industry

Predictive maintenance

Smart Home

Event detection

Smart Farming

Optimizing conditions

Personal Healthcare

Body measurements

AI is used today in almost every market segment

157

Robots

Collision detection



Growing community and ecosystem of Deep Edge AI technologies focusing on 

standalone, low-power and cost-efficient embedded solutions.

Embedded AI technology trend

AI technologies are now 

embedded inside end devices 

(MPU, MCU and sensors).

MCU MPU

“Global Shipments of Deep Edge AI Devices 

to Reach 2.5 Billion by 2030”
Source: ABI Research

158

https://www.prnewswire.com/news-releases/global-shipments-of-tinyml-devices-to-reach-2-5-billion-by-2030--301123076.html


The quest for an ever-SMARTER infrastructure
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Embedded AI

Edge

Reporting 

Observation:

IoT

Remote AI

Cloud 

Value

Time

Local 

functions

Offline era Online era Onlife era

Fragmented Connected Trained



Artificial intelligence at the Edge
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Moving part of Artificial Intelligence closer to the data acquisition 

brings several benefits

Privacy by design 

GDPR compliant

Sustainable on energy

Low-power consumption

Better user experience

Ultra-low latency

Real-time applications

More reliability

Security of data

No sharing in the cloud



A step too big to climb
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1.2Million 0.2%

With some AI skills

130,000

Data Scientist shortfall in the US 
(IBM Quant Crunch Report)

74%   

FAILURE RATE FOR AI.IOT PROJECTS
(Cisco Connected Research Futures) Lack of adequate data sets

Lack of data scientists

15Months

Average time to collect & label data
(Mc Kinsey)

EMBEDDED DEVELOPERS
(IDC)

Organizations main challenges – AI Skills & datasets



For most companies, creating an edge AI device is a 
long journey with extraordinary challenges
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Cloud

dependency

No qualified 

data sets 

Lack of data 

science resources

RAM & energy

voracious

Important upfront 

investment

Investment, complexity and development time are often barriers to AI adoption



Start today with deep edge AI 

This is where we come in



Whatever your company's profile, 
you will find an AI solution suited to your needs
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Embedded developers

▪ No dataset available

▪ No dedicated AI Team

Team with AI expertise

▪ Dataset available

▪ AI Team

Deep LearningClassificationAnomaly detection

Engineering 

Services

USE CASES

COMPANY’S PROFILE



STM32 comprehensive AI ecosystem

Applicative 

Examples
(Function Packs)

Applications Frameworks

Discovery kit STM32 Nucleo board Camera add-on

AI Model convertor

Quantizer
Graph

optimizer

Memory 

optimizer

Edge Hardware

STM32 series

Pre and post 

Processing 

libraries

165



A tool to seamlessly integrate AI in your projects

Machine Learning

Deep Learning

Select MCU & upload your model 

Optimize and validate

Generate project and deploy

HIGH PERFORMANCE

EDGE AI PRODUCT

166



For embedded developers
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NanoEdge™ AI Studio, an automated ML design solution

• Patented technology

• Designed for embedded developers 

• Ultra memory efficient (Flash and RAM)

• Unsupervised learning in the device

• No dataset need

• Superior security

• Small footprint, runs on any STM32 microcontroller

• Close to 100% accuracy and confidence

• For anomaly detection, classification and extrapolation problems

A unique solution thought from scratch 

HOW DID WE DO IT? 

We re-wrote, from the algebra, ML and signal processing 

algorithms so that they can LEARN and INFER inside STM32



For teams with AI expertise

168

STM32Cube.AI helps you accelerate your embedded development

• Develop and train your model with major AI frameworks

• Best ML performance on STM32 (MLPerf™ Tiny benchmarks)

• Validate performance directly on target

• Small footprint, runs on any STM32

• To address any kind of problem with ML or CNN libraries

Easily evaluate, convert and deploy Machine Learning and 

Deep Neural Networks on STM32

An AI extension integrated with STM32Cube MCU 

development environment to OPTIMIZE and TUNE models, 

directly on target



Making Edge AI accessible to all STM32 portfolio
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STM32F3

245 CoreMark

72 MHz Cortex-M4

STM32H7

Up to 3224 CoreMark

Up to 550 MHz Cortex -M7

240 MHz Cortex -M4
Optimized for mixed-signal Applications

STM32MP1

4158 CoreMark

Up to 800 MHz Cortex –A7

209 MHz Cortex –M4

STM32F2

Up to 398 CoreMark

120 MHz Cortex-M3

STM32F4

Up to 608 CoreMark

180 MHz Cortex-M4

STM32F7

1082 CoreMark

216 MHz Cortex-M7

STM32F0

106 CoreMark

48 MHz Cortex-M0

STM32G0

142 CoreMark

64 MHz Cortex-M0+

STM32F1

177 CoreMark

72 MHz Cortex-M3

STM32L0

75 CoreMark

32 MHz Cortex-M0+

STM32L1

93 CoreMark

32 MHz Cortex-M3

STM32L4

273 CoreMark

80 MHz Cortex-M4

STM32L4+

409 CoreMark

120 MHz Cortex-M4

STM32L5

443 CoreMark

110 MHz Cortex-M33

STM32U5

651 CoreMark

160 MHz Cortex-M33

STM32WL

162 CoreMark

48 MHz Cortex-M4

48 MHz Cortex-M0+

STM32WB

216 CoreMark

64 MHz Cortex-M4

32 MHz Cortex-M0+

High Perf

MCUs

Ultra-low Power

MCUs

Wireless

MCUs

Mainstream

MCUs

MPU

Latest product generation

STM32G4

569 CoreMark

170 MHz Cortex-M4

STM32Cube.AI & NanoEdge AI are compatible with all STM32 series



Integrate your ML models more easily 
with our application-oriented code examples
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Face recognition

FP-AI-FACEREC1

• Face detection and 

recognition

• Fully functional without 

cloud connection

Time series-based 

monitoring

FP-AI-MONITOR1

• Predictive maintenance and 

much more sensor-

monitoring apps

• Runs Libraries from 

NanoEdge™AI Studio

Audio and Sensing

FP-AI-SENSING1

• Human Activity Recognition

• Acoustic Scene 

Classification

• Data logging, labeling and 

result on BLE applications

FP-AI-VISION1

• Food recognition (CNN)

• Person presence detection 

(CNN)

• People counting (Object 

detection NN)

• Image processing Library

Computer Vision



We provide everything to kick off your project
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• Wiki by ST is a great forum to learn and 

start developing AI on STM32! 

• Videos of application examples

• Massive Open Online Course (MOOC)

Hardware and software toolsDesign documentation

• Evaluation platforms for STM32 

MCU/MPU

• Extra sensor boards

• Full software suite

Support & Updates

• ST Community: STM32 ML & AI group

• Competence center

• Distributor certified FAE

• Support center

• Newsletter

Development zoneGetting started

Be guided step-by-

step to learn 

STM32 ecosystem

Get started on 

application 

development and 

project sharing

Stay focused on your expertise, we bring you everything else



Information and sharing: ST worldwide
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Get connected to STM32 world!

►STM32 Education is now available here (MOOC, OLT, Textbooks, Training Courses)

st.com/stm32

Information

ST MCU Finder

Product Selector

community.st.com

Community/GitHub

facebook.com/stm32

youtube.com/STonlineMedia

twitter.com/@ST_World

linkedin.com/stmicroelectronics

21IC 

YouKu

Social Media

github.com/STMicroelectronics

www.st.com/stm32education

http://www.st.com/content/st_com/en/support/learning/stm32-education.html
http://www.st.com/stm32
http://www.st.com/stmcufinder
https://community.st.com/s/topic/0TO0X000000BSqSWAW/stm32-mcus
http://facebook.com/stm32
https://www.youtube.com/playlist?list=PLnMKNibPkDnF97QnUOFGirl1q0G_4VdDc
mailto:twitter.com/@ST_World
https://www.linkedin.com/company/stmicroelectronics
http://bbs.21ic.com/iclist-49-1.html
http://i.youku.com/u/UNTM5NTAyMTky
https://github.com/STMicroelectronics
http://www.st.com/stm32education
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