error in programming(cant load flash device description)

hi i'm using keil 5 and st link v2 programmer .i can't program micro with keil and this error appears :

i looked into CMSIS file i found 5.8.0 folder but there was no Flash folder so i downloaded STM32F10x_128.FLM file from internet and create a flash folder and placed STM32F10x_128.FLM file in Flash folder 

this doen't work.

i see in option\debug\setting it finds micro but it can't program it.

so after that i tried to program micro by stmcubeprogrammer it connects to micro but it cant program it and error comes.i uploaded the picture of errors below

i didnt have this problem before, after changing my windows and installing keil again this happened

appreciate your help.

  • That an STM32F1xx Flash Programming Algorithm file is searched in the CMSIS pack folder is very strange. Not sure, how have you set up (or messed up) this project. Really strange. So, better to start from scratch.

    What target hardware/board are you using? Is this some NUCLEO or Discovery board with some STM32F1 device?

    For the STM32F1 devices, you should have installed the STM32F1xx_DFP, current version 2.3.0, with the PackInstaller. This should also contain the required Flash Programming Algorithms! Have you installed this pack?

    If yes, check the PackInstaller examples tab, if there is an example project available for your board and use this. Can you build and flash and debug such a preconfigured example?

    If not, and also the ST tools still fail to access your board, then please also contact ST directly regarding this, on how to unlock the device again.

More questions in this forum
There are no posts to show. This could be because there are no posts in this forum or due to a filter.