S32K1 startup codes for V6.15 and V5.06 update 7

I need to use ARM compiler V5.06 update 7 not only V6.15 in a project of S32K144 for some backward compatibility issues.

Please, recognize the following 2 pictures:

This is when I use compiler V6:

This is when I use V5:

The startup code is available in V6 only. Does this mean that I can not compile S32K144 codes with V5 or at least it will not work ?

Actually I tried to use the same startup code of V6 while compiling with V5 and it did compile with 0 errors, 0 warnings but the code never runs on the target and can not debug it (while using V5) to know the root cause.

What could be the root cause of such a problem and why there is no available startup code when choosing V5 in the "Options for Target" ?

More questions in this forum