Keil adding new device core ARM926EJ-S

I have development board with Chinese ARM926EJ-S MCU. It also has NAND flash for booting and SDRAM. I also have a sample project developed in ADS 1.2 and LPT JLINK which works only in Windows XP. I never used that JTAG.

I migrated that project into KEIL 5. Compiled binary file burned into NAND by external tools is working now with MCU. I want to use JTAG debugging with Segger Jlink.

In accordance of this https://www.keil.com/pack/doc/CMSIS/Pack/html/cp_SWComponents.html I created a software pack for KEIL. Now in Keil I can select my MCU.

When I start Debugging in Keil I see log message "No Algorithm found for: 32100000H - 3210FFFFH". As I see Keil tries to burn the binary file into flash memory. Mentioned addresses are internal execution memory of my MCU (it is RAM memory for code).

What I have to do for loading execution code into that memory space and start execution. At this time I don't need NAND flash programming.  

Parents
  • I've got a project that can run load and run from RAM on an LPC45S018M. The project settings were:

    1. Linker

    • Use a dedicated scatter file, don't use the target settings dialog to make the scatter file.

    2. Debugger

    • Disable Load Application at Startup
    • Use an INI file (more on that below)

    3. Debugger : Settings : Debug

    • Disable the download options
    • You may need to adjust the Connect and Reset options. These worked for my LPC54S018M. VECTRESET doesn't reset peripherals (or RAM).

    4. Debugger : Settings : Flash Download

    • Set to Do Not Erase

    The INI file is simple:

    LOAD $L%L INCREMENTAL
    RESET
    G ,main
    

Reply
  • I've got a project that can run load and run from RAM on an LPC45S018M. The project settings were:

    1. Linker

    • Use a dedicated scatter file, don't use the target settings dialog to make the scatter file.

    2. Debugger

    • Disable Load Application at Startup
    • Use an INI file (more on that below)

    3. Debugger : Settings : Debug

    • Disable the download options
    • You may need to adjust the Connect and Reset options. These worked for my LPC54S018M. VECTRESET doesn't reset peripherals (or RAM).

    4. Debugger : Settings : Flash Download

    • Set to Do Not Erase

    The INI file is simple:

    LOAD $L%L INCREMENTAL
    RESET
    G ,main
    

Children
No data
More questions in this forum