ARM: Simulator won't run unmodified Blinky

Newbie here. I've spent about a day digging through app notes and previous postings and don't see the answer to this. I have an MCB2929, though we are waiting for the ULINK box. Therefore I am trying to just compile code and run it in the simulator on the PC.

So out of the box, I tried the Blinky app. Compiles fine, no errors or warnings. But I get the "error 65: Access violation at 0x00000000" error when I try to run the simulator in the PC. This particular board has the memory at 0x020000000, and the memory map reflects this. The program counter for some reason starts at address 0, where there is no memory.

So what do I need to do to get this to start at the proper location? I would have thought this would work out of the box.

Just for fun I tried the "Hello, world" program at C:\Keil\ARM\Examples\Hello and it works properly.


More questions in this forum
There are no posts to show. This could be because there are no posts in this forum or due to a filter.