Error: Wrong version of armctmodel.

Hi, I am using ARM DS 2021.1 IDE with a Eval license for Cortex-A35x4 SMP platform. As there was no FVP for this platform, I downloaded the FVP library which has the needed FVP i.e. FVP_Base_Cortex-A35x4.exe. After this when I try to launch the debugger I am getting the below error

"ERROR: uncaught exception occured. Exception message follows:
Error: Wrong version of armctmodel. Version 11.14.21 (API Version 1.2) of the Portfolio was used to build the model. Please use identical major.minor versions of the Portfolio and the Tools."

I saw earlier posts with similar error but that was on DS 2020 and to do with the file eval.elmap file which I believe is fixed in DS 2021.1 version of IDE!

Any help to resolve this is much appreciated :)

Regards,

Shivaprasad.

Parents
  • Hello, I did a quick test with the latest version of the FVP library, and could not reproduce the issue. I was able to launch and connect to the model without problem. I am on Windows.

    Have you specified any additional plugins to your model? That is usually the root cause of such an error, as they must match the version number.

    May I suggest you raise an official support case from the support menu above if you wish for Arm engineers to investigate.

Reply
  • Hello, I did a quick test with the latest version of the FVP library, and could not reproduce the issue. I was able to launch and connect to the model without problem. I am on Windows.

    Have you specified any additional plugins to your model? That is usually the root cause of such an error, as they must match the version number.

    May I suggest you raise an official support case from the support menu above if you wish for Arm engineers to investigate.

Children
More questions in this forum
There are no posts to show. This could be because there are no posts in this forum or due to a filter.