DS52020.0 connection to Musca-A/B boards not working

Hi guys,

Going straight to the point, we recently had access to a license for Arm DS52020.0 and while trying to start a debug connection to Musca-A1 or B1 boards we are getting a failed connection output. 

I tried to install the tool on both a Linux and Windows systems. 

1) On Linux, I created a new "Generic Arm C/C++ Application" debug configuration. I selected the target to connect and changed the type of connection to "CMSIS-DAP". For both platforms, I can't browse the connection. More specifically, when I open the "Browse" window the connection is there, but when I try to select it, the option just simply disappears. 

2) On Windows, I followed the same steps, but I was able to select the target on the "Connection Browser" window. On the Debugger tab I selected the option "Debug from symbol" after given the application path to be downloaded to the target. As soon as I start the Debug session I get the following errors for each board:

Musca-A1

  

Musca-B1

Is there something that I'm doing wrong ?

Thank you.

Parents Reply
  • , first and foremost thank you for the answer. I indeed followed your blog post. The major difference that I see is that I'm trying to connect without the DSTREAM and via USB cable. Despite that, I tried to connect to the board by following your power-up steps:

    1) Pressed ISP button and connected the USB cable. 

    2) Pressed HWRST and after PBON button to power up the board (I also advanced to step 3 without PBON pressed, no luck either). 

    3) Tried to establish the connection and I received the same error. 

    No luck! Any ideas?

    PS: I just tried this for Musca-A1, since B1 afaik don't provide a HWRST button. 

    PS2: I should also mention that the DAPLink firmware that I'm using is the last available here.

Children
More questions in this forum