ARM compiler upgrade

We are considering to upgrade ARM compiler from 4.1 to ARM compiler v5.06 or even to compiler 6.13. The projects we are mainly working for is with architecture ARMv5TEJ

Evaluation for ARM 6.13 is started and following errors are obtained

armclang: error: unsupported option '--c90'
armclang: error: unsupported option '--diag_error'
armclang: error: unsupported option '--cpu'
armclang: error: unsupported option '--li'
armclang: error: unsupported option '--list'
armclang: error: unsupported option '--diag_remark'
armclang: error: unsupported option '--diag_error'
armclang: error: unsupported option '--sys_include'
armclang: error: unsupported option '--kandr_include'
armclang: error: unsupported option '--library_interface=aeabi_clib'
armclang: error: unsupported option '–dwarf2'

And armclang no longer provide the compile switch for ARMv5 architecture.

Please advise if there is any alternative & compatible compile switches to resolve compile/link problem.

By the way, is ARM compiler 5.06 still available for purchase and provide support ?

More questions in this forum