library files

I downloaded a pwm library and ı would like to add those to my keil project window. I created a new file group from Project workspace of KEIL. And ı added all .c and .h files. When ı include those libraries ı got "fatal error: ..... file not found" error. So What ı am doing wrong?

Parents
  • Why have you not posted this in the Keil forum?

    a pwm library

    By "library" here, you mean just a set of source files - rather than an actual, pre-built binary library file?

    Such source files are no different to any other source files.

    Are you sure this library is intended for use with Keil?

    It would help to give a link so that we know what you're talking about.

    ı added all .c and .h files

    Note that there's no need to add .h files to the project - the compiler will find those for itself via the Include Paths setting.

    It doesn't hurt to add them, but it also does not help the compiler to find them - you still need to correctly configure the Include Paths.

    ı got "fatal error: ..... file not found" error

    Where, exactly, did you get that?

    Also, Please copy & paste the complete message

    What ı am doing wrong?

    Not setting up the Include Paths?

    Have you worked through Keil's learning page:

    http://www2.keil.com/mdk5/learn

Reply
  • Why have you not posted this in the Keil forum?

    a pwm library

    By "library" here, you mean just a set of source files - rather than an actual, pre-built binary library file?

    Such source files are no different to any other source files.

    Are you sure this library is intended for use with Keil?

    It would help to give a link so that we know what you're talking about.

    ı added all .c and .h files

    Note that there's no need to add .h files to the project - the compiler will find those for itself via the Include Paths setting.

    It doesn't hurt to add them, but it also does not help the compiler to find them - you still need to correctly configure the Include Paths.

    ı got "fatal error: ..... file not found" error

    Where, exactly, did you get that?

    Also, Please copy & paste the complete message

    What ı am doing wrong?

    Not setting up the Include Paths?

    Have you worked through Keil's learning page:

    http://www2.keil.com/mdk5/learn

Children
No data
More questions in this forum