Accessing coresight debug and trace memory region in EL3 leads to stuck.

The manual tells that I can use ETM in both self-host debugging and external debugging. With DStream and DS-5, the ETM works well. However, i find that i can not modify the tracing registers in DS-5, the command always leads to "verify error on memory operation".

Moreover, can i use ETM without JTAG and DStream? I mean i want to enable the tracing and read the ETB from the EL3, i guess it should be feasible as it supports self-host debugging. However, after i plug out the JTAG, I can not read the memory region CSS_DEVICE in trusted firmware. I checked the manual, all the debugging related (CTI, ETM, trace) components are mapped to this region (0x20000000-0x2e000000), but the read operation to this region in EL3 leads to stuck. I am really confused about it. I have checked the MMU page tables and even tried to disable MMU, but i still got stuck.

Really appreciate for any help!


Edit 09/02/2016: Not only the ETM, if i try to read from the coresight debug and trace memory region (0x20000000-0x23350000) in EL3 without plugging in JTAG, the system just stuck there. I think it is not caused by memory mapping as i got the same result even if i temporarily disabled the MMU. Did i miss something special?

Parents Reply Children
No data
More questions in this forum