gatord refusing to copy to /data/data/%APP_NAME%/

Hi, everyone!

I'm trying to profile a Unity application using Streamline on a Samsung A20e. However I'm stuck in the process, because gatord is refusing to copy to the target app directory.

Steps I have done:

-Build a development build of the app (Also tried to set it explicitly to debuggable  in the manifest)

-Deploy the app on the phone

-Run the app

-Close the app

-execute gatorme.bat (this is the default gatorme.bat from github)

I'm calling gatorme.bat like this:

gatorme.bat com.replaced.replaced G71 ./bin/gatord

gatorme.bat fails on the following line:

adb shell run-as com.replaced.replaced cp /data/local/tmp/gatord /data/data/com.replaced.replaced/

With this error message:

cp: Skipped dir '/data/data/com.replaced.replaced//gatord': No such file or directory

Stuff I tried that didn't fix the problem:

-Fix the double slashes in the path.

-Make the app explicitly debuggable in AndroidManifest.xml

-Copy gatord by hand to Android/data/com.replaced.replaced (but I'm guessing this isn't the same path)

Any help would be welcome!


More questions in this forum
There are no posts to show. This could be because there are no posts in this forum or due to a filter.