Can code compiled for armv7-m run as it is on armv8-m?

Some white paper says:

*The new architecture is upward compatible with existing ARMv6-M and ARMv7-M architectures.

Is it means code compiled for arv7-m can run on armv8-m non secure mode?

*Summary on page 16 in community.arm.com/.../Whitepaper-_2D00_-ARMv8_2D00_M-Architecture-Technical-Overview.pdf

More questions in this forum