Error: Cannot Load Flash Programming Algorithm!

Hi, i have these problem and searched fore different solutions but none worked for me, i will explain here.

Environment:

  • Keil 5.34
  • STM32H745I-DISCO (with embedded ST-LINK/V3)
  • Code generated with STM32CubeMX
  • Pack Keil.STM32H7xx_DFP.2.7.0

The Keil program searches into C:\Users\username\AppData\Local\Arm\Packs\Keil\STM32H7xx_DFP\2.7.0\Flash\STM32H7xx.FLM, but the current FLM is into C:\Users\silvestros\AppData\Local\Arm\Packs\Keil\STM32H7xx_DFP\2.7.0\CMSIS\Flash\STM32H7xx.FLM

Things that I've tryed:

  1. reinstall the Pack Keil.STM32H7xx_DFP.2.7.0 -> nothing appened
  2. Copying the Flash folder where the Keil searches for it -> nothing appened
  3. Reflashed and updated the ST-LINK firmware -> nothing appened
  4. As suggested here https://community.st.com/s/question/0D50X0000APZgDi/cannot-flashdebug-stm32f072-discovery-board tryed erasing the full chip with ST-lLINK Utility -> nothing appened

With some ST examples (with the relative keil project) I'm able to correctly flash the firmware, I cheched the debugger config and seems the same to my eyes.

Don't know what else to do.

Thanks

Parents
  • SOLVED

    Go to Project > Options for target xxxxx-CM4 > Debug > (continue under)
    on the top right ST-link Debugger selected click on Settings > Flash Download and in the RAM for Algorithm use:

    Start: 0x20000000    Size: 0x00001000


    Originally, these value were the same for CM4 and CM7 target ( Start: 0x10000000    Size: 0x00001000)

    Hope it helps.

    Bye

Reply
  • SOLVED

    Go to Project > Options for target xxxxx-CM4 > Debug > (continue under)
    on the top right ST-link Debugger selected click on Settings > Flash Download and in the RAM for Algorithm use:

    Start: 0x20000000    Size: 0x00001000


    Originally, these value were the same for CM4 and CM7 target ( Start: 0x10000000    Size: 0x00001000)

    Hope it helps.

    Bye

Children
No data