1 Reply Latest reply: Jul 25, 2014 9:29 AM by joealderson RSS

Install ds5_update_site.zip gives error

rocketdawg Null

Just installed DS-5 Vybrid version

then tried to install MQX RTOS viewer

there are also Eclipse updates available, but they complain about "access privileges"

The default install dir is "Program Files/DS-5"  and I have never in the past installed Eclipse there.

I am thinking there will be issues.  like the space in "Program Files" and permissions.

 

 

 

Cannot complete the install because one or more required items could not be found.

Software currently installed: Freescale MQX support for ARM DS-5 1.0.2.201307020935 (com.freescale.mqx.ds5.feature.group 1.0.2.201307020935)

Missing requirement: MQX Configuration Editor 1.1.6.201307020935 (com.freescale.mqx.configuration.editor 1.1.6.201307020935) requires 'bundle org.eclipse.core.runtime [3.7.0,3.8.0)' but it could not be found

Cannot satisfy dependency:

From: Freescale MQX support for ARM DS-5 1.0.2.201307020935 (com.freescale.mqx.ds5.feature.group 1.0.2.201307020935)

To: com.freescale.mqx.configuration.editor [1.1.6.201307020935]

 

System Information:

  OS name: Windows 7

  Java version: Java HotSpot(TM) Server VM, 24.60-b09

  PATH environment variable: C:/Program Files/DS-5/bin/../sw/eclipse//../java/bin/server;C:/Program Files/DS-5/bin/../sw/eclipse//../java/bin;C:/Program Files/DS-5/bin/../sw/eclipse//../java/lib/i386;C:\Program Files\DS-5\bin;C:\Program Files\DS-5\sw\java\bin;C:\Program Files\Parallels\Parallels Tools\Applications;C:\Windows\system32;C:\Windows;C:\Windows\System32\Wbem;C:\Windows\System32\WindowsPowerShell\v1.0\;C:\Program Files\TortoiseSVN\bin;C:\Program Files\Git\cmd;C:\Program Files\Git\bin;C:\Program Files\Microsoft\Web Platform Installer\;C:\Program Files\Microsoft ASP.NET\ASP.NET Web Pages\v1.0\;C:\Program Files\Windows Kits\8.0\Windows Performance Toolkit\;C:\Program Files\Microsoft SQL Server\110\Tools\Binn\;c:\nant-0.90\bin;C:\Program Files\Microsoft Network Monitor 3\;c:\MinGW\bin;c:\Python27;C:\GCC\bin;C:\Windows\system32;

 

 

Product Information:

  Version: 5.19.0

  Build number: 5190027

  Build date: 201407

  Selected toolkit: DS-5 Vybrid Tower System Starter Kit

  ARM_DS_TOOLKIT_KEY environment variable: vf6xx_sk

  arm.ds.toolkit.key system property: vf6xx_sk

 

 

Host IDs:

  001C42C948A9: Intel(R) PRO/1000 MT Network Connection

 

 

Licenses are searched for in the following locations:

  ARMLMD_LICENSE_FILE environment variable: "C:\Users\xxx\AppData\Roaming\ARM\DS-5\licenses"

  LM_LICENSE_FILE environment variable: not set

  DS-5 licenses directory: "C:\Users\xxx\AppData\Roaming\ARM\DS-5\licenses"

 

 

Licenses used recently (Streamline and DS-5 Debugger only):

  [vf6xx_sk_ds_debugger_cmsisdap/5.0201407], valid until Jul 18 2015

 

 

License checkout log (Streamline and DS-5 Debugger only):

  18/07/2014 12:13:56: [vf6xx_sk_ds_debugger_cmsisdap/5.0201407], valid until Jul 18 2015

  • Re: Install ds5_update_site.zip gives error
    joealderson Employee

    Hi rocketdawg,

     

    This line:

    Missing requirement: MQX Configuration Editor 1.1.6.201307020935 (com.freescale.mqx.configuration.editor 1.1.6.201307020935) requires 'bundle org.eclipse.core.runtime [3.7.0,3.8.0)' but it could not be found

    means that MQX Configuration Editor is dependent on Eclipse v3.7 to 3.8.

     

    DS-5 v5.18 and v5.19 uses Eclipse v4.3, so you have two options:

     

    - Use DS-5 v5.17, which had Eclipse v3.7. You can find it in the "Older Releases" tab here: http://ds.arm.com/downloads/

    - Contact Freescale for information on whether they're planning to update MQX Configuration Editor to support Eclipse 4.3.

     

    Hope this helps,

     

    Joe